在vue-cli中使用less

进入项目下载less和less-loader依赖

less为开发应用时所依赖的工具包,所以应该安装在devDependencies中

npm install less less-loader -D

-D为--save --dev的缩写,意思为将依赖包安装在devDependencies中,devDependencies中放置开发应用时所依赖的工具包。通常是一些开发、测试、打包工具,例如 webpack、ESLint、Mocha。应用正常运行并不依赖于这些包,用户在使用 npm install 安装你的包时也不会安装这些依赖。

-S为--save的缩写,意思为将依赖包安装在dependencies中,dependencies:应用能够正常运行所依赖的包,这种 dependencies 是最常见的,用户在使用 npm install 安装你的包时会自动安装这些依赖。

使用
<template>
    <div class="test"></div>
</template>

<style lang='less' scoped>
    .test {
        width: 100px;
    } 
</style>

style标签里加上 scoped 为只在此作用域有效

发表评论

您的电子邮箱地址不会被公开。